Estructuras de Control

julymarcm
Mind Map by julymarcm, updated more than 1 year ago
julymarcm
Created by julymarcm almost 6 years ago
4
0

Description

estructuras de seleción y repetitvas

Resource summary

Estructuras de Control
1 Repetitivas
1.1 Para (for)
1.1.1 Inicio Int: i Real: acum, variable. acum<-0 para i :(1 hasta x) Escriba "Digite dato numero" i Lea variable acum<-acum+variable FinPara Escribir "el acumulado final es" acum Fin
1.2 Mientras (while)
1.2.1 inicio Int.n Real: acum, operación n<-1 Mientras (n cumpla condición) Hacer escribir "Digite variable" n leer variable acum<-acum+variable n<-n+1 Fin Mientras ejecute operación Escribir "el resultado de la operación es" operación Fin
1.3 Repita hasta (do while)
1.3.1 inicio int: op real: tcompra, compra tcompra<-0 Repetir Escribir "Digite el valor de la compra" Leer compra tcompra<-tcompra+compra Escribir "Desea ditar nueva compra si(1)/no(2)" Leer op Hasta Que OP=2 ganancia<-tcompra*(0.25) Escribir "El total comprado es : " tcompra Escribir "La gancia es: " ganancia Fin
2 Selectivas
2.1 Simples
2.1.1 Si (if)
2.1.1.1 Inicio Real variable; Lea variable; Si (variable cumple condición) Entonces Escribir ‘mensaje de salida’ FinSi Fin
2.2 Dobles
2.2.1 Anidadas
2.2.1.1 Si-Sino-Sino o Caso (if-else-case o else)
2.2.1.1.1 Inicio Entero: variable 1, variable 2 Real: Resultado Cadena: condición Escribir “ingrese primer variable” Lea variable1 Escribir “ingrese segunda variable” Lea variable 2 Escribir “ingrese opción” Lea condición Si (condición "opción" se cumple) entonces Resultado variable 1 "opcion" variable 2 Sino Si (condición "opción" se cumple ahora) entonces Resultado variable 1 "opción" variable 2 Sino Si (condición "opción" se cumple ahora) entonces Resultado variable 1 "opción" variable 2 FinSi FinSi FinSi
2.2.2 Si-Sino (if-else)
2.2.2.1 Inicio Int variable; Escribir “Digite variable” Lea variable Si (variable cumple condición) Entonces Escribir 'mensaje de salida' Sino Escribir "mensaje de salida alterno" FinSi Fin
2.3 Multiples
2.3.1 Caso (case)
2.3.1.1 Inicio Escribir "Elija una opción (1-7): " Leer opción Caso (opción) Hacer 1: Escribir "caso 1" 2: Escribir "caso 2" 3: Escribir "caso 3" 4: Escribir "caso 4" 5: Escribir "caso 5" 6: Escribir "caso 6" 7: Escribir "caso 7" De otro modo: Escribir "caso no válido" Fin Fininicio
Show full summary Hide full summary

Similar

Operadores Python
Giovanni Sanhuez
Mis Recursos de Programación
maya velasquez
FUNDAMENTOS DE REDES DE COMPUTADORAS
anhita
Editor Dibujo Paint
gladiscj
Herramientas de Software para Comercio y Finanzas
mishelleisabel
Estructuras Algorítmicas
Willian Torres Q
Sistemas Operativos
Samuel Hernandez
Introducción a la programación
Carol Arguello
Programación
Adri ViMo
ALGORITMOS
FCAMARGO
redes inalambrica
Jordan Rosario. A