Las Estructuras de Control

Marquiño Silver  Zubileta Contreras
Mind Map by , created about 3 years ago

Las estructuras de control

20
0
0
Marquiño Silver  Zubileta Contreras
Created by Marquiño Silver Zubileta Contreras about 3 years ago
EJEMPLOS DE CICLOS
Isabel Morales
Test PYTHON
peralesmagana
Desarrollo web
William Valdez
Grade 8 Week 7 Vocabulary
J L
Family in the park
Eleuterio Caicedo Valencia
Latex
Maye Tapia
Introducción a la Programación
Diego Benavides
Interface en Java
tavoberry
Errores comunes en programación
Luciao Agustín Correa Sapiega
Las Estructuras de Control
1 Controlar la ejecucion de Instrucciones del programa
2 Tipos
2.1 Estructuras de Control de Selección
2.1.1 las instrucciones de un programa se ejecutan secuencialmente
2.1.2 Selección Simple
2.1.2.1 Ejemplo : Aplicar el 15% de descuento a un monto, si éste es >= 100000. Si (monto >= 100000) Entonces monto ß monto – (monto * 0.15) Fin Si
2.1.2.2 permitir elegir dos caminos dependiendo del valor de verdad de una fórmula lógica
2.1.3 Selección Doble
2.1.3.1 Ejemplo: Actualizar el saldo de una cuenta bancaria, a partir de un retiro. Si ((Saldo – Retiro) >= 0) Entonces Saldo ß Saldo - Retiro Sino Escribir “Fondos Insuficientes” Fin Si
2.1.3.2 controlar la ejecución de varias acciones y se utilizan cuando se tienen dos opciones de acción
2.1.4 Selección Múltiple
2.1.4.1 Ejemplo: Costo de una pizza, según su tamaño. Caso (Tamaño_Pizza) ‘P’: Costo ß 6000 ‘M’: Costo ß 8000 ‘G’: Costo ß 10000 Sino Escribir “Tamaño de Pizza no válido“ Costo ß 0 Fin Caso
2.1.4.2 evalúar una expresión que puede tomar n valores distintos (1, 2, 3, ..., n)
2.1.5 Selección Simple Anidada
2.1.5.1 Ejemplo : Aplicar el 15% de descuento a un monto, si éste es >= 100000 y si el resultado es mayor 400000 se le aplicará 10%. Si (monto >= 100000) Entonces monto ß monto – (monto * 0.15) Si (Monto > 400000) Entonces monto ß monto – (monto * 0.10) Fin Si Fin Si
2.1.5.2 permite dividir el flujo de nuestros programas en n caminos distintos.
2.1.6 Selección Doble Anidada
2.1.6.1 Ejemplo: Actualizar el saldo de una cuenta bancaria, a partir de un retiro si el saldo es mayor o igual a 100000 se le restará 1500, si el saldo es menor de 100000 se le restará 1000. Si ((Saldo – Retiro) >= 0) Entonces Saldo ß Saldo – Retiro Si (Saldo >= 100000) Entonces Saldo ß Saldo - 1500 Sino Saldo ß Saldo - 1000 Fin Si Sino Escribir “Fondos Insuficientes” Fin Si
2.1.6.2 Contiene diferentes alternativas o acciones.
2.2 Estructuras de control repetitivas/iterativas
2.2.1 Ejecutar una o las instrucciones más de una vez
2.2.2 Variables Auxliares
2.2.2.1 Contador
2.2.2.1.1 su valor se incrementa o decrementa en una cantidad
2.2.2.2 Acumulador
2.2.2.2.1 almacenar cantidades resultantes de sumas sucesivas
2.2.3 Estructura Repetitiva Mientras / hacer :
2.2.3.1 Ejemplo: Estructura repetitiva para sumar los precios de 3 artículos. Suma ß 0 Articulo ß 0 Mientras (Articulo < 3) Hacer Articulo ß Articulo + 1 Escribir “Introduzca Precio del Artículo # ”, Articulo Leer (Precio) Suma ß Suma + Precio Fin Mientras Escribir “El resultado de la suma es = “, Suma
2.2.4 Estructura Repetitiva Para:
2.2.4.1 Ejemplo:Para V<---VI hasta VF incremento 1 Hacer Bloque de instrucciones Fin_para
3 Ventajas
3.1 Los programas son más fáciles de entender
3.2 Se logra una reducción del esfuerzo en las pruebas, el seguimiento de las fallas o depuración.