Questão 1
Questão
Con respecto a la seguridad lógica, se quiere crear un usuario “operador” perteneciente al grupo “investigadores” donde se especifique la Shell que usará y su home. ¿Cuál sería la manera correcta?
Responda
-
Createuser –g investigadores –s /bin/bash –d /home/operador operador
-
useradd–g investigadores –s /bin/bash –d /home/operador operador
-
Createuser –g investigadores –s /bin/bash –h /home/operador operador
-
useradd–g investigadores –s /bin/bash –h /home/operador operador
Questão 2
Questão
Si queremos restringir el almacenamiento en disco en Linux a determinados usuarios o grupos, ¿cuál de los siguientes métodos podemos usar?
Responda
-
Mediante cuotas de disco.
-
Mediante el editor de directivas de grupo.
-
No se puede restringir el almacenamiento a usuarios.
-
No se puede restringir el almacenamiento por grupos.
Questão 3
Questão
El comando en Linux que muestra los usuarios conectados al sistema y el tiempo de conexión es:
Questão 4
Questão
El comando LINUX que muestra fecha y hora del último reinicio del sistema es:
Responda
-
who -b
-
reboot
-
who -u
-
whoami
Questão 5
Questão
En las comunicaciones a través de sockets, ¿cuál de las siguientes NO se corresponde con una primitiva?
Responda
-
Bind
-
Listen
-
Reject
-
Socket
Questão 6
Questão
Es necesario que se actualice el servidor S1 al último software disponible, ¿cuál, de las siguientes, sería las órdenes que debería ejecutar?
Responda
-
apt-get update; apt-get dist-upgrade;
-
apt-get dist-install; apt-get update;
-
apt-cache update; apt-dist upgrade;
-
apt-dist update; apt-get install –all;
Questão 7
Questão
Señale cuál de las siguientes respuestas se corresponde con el administrador de paquetes para sistemas RedHat y Fedora entre otros:
Responda
-
Apt-get update
-
Apt-get update all
-
Yum update
-
Yum lastest
Questão 8
Questão
Existen unas máquinas con un Red Hat Enterprise Linux antiguo (RHEL versión Tikanga 5.5) y de cara a migrar a una versión más actual se necesitan listar los paquetes instalados. ¿Cómo lo haría?
Responda
-
Rpm –qi
-
Rpm –qa
-
Rpm –a
-
Rpm-al
Questão 9
Questão
Se le pide que se haga un backup de todas las bases de datos, indique cuál es el comando para realizarlo:
Responda
-
mysqldump –all-databases –u=u_mysql –p=xyz > /tmp/backup.sql
-
mysqldump –all-databases –u u_mysql -pxyz > /tmp/backup.sql
-
mysql –bakcup –all-databases –u=u_mysql –p=xyz > /tmp/backup.sql
-
mysql –all-databases –u u_mysql -pxyz > /tmp/backup.sql
Questão 10
Questão
La Guía CCN-STIC-461 sobre seguridad en Drupal, recomienda una vez instalado cambiar el usuario administrador de la base de datos MySQL, ¿cuál sería ese comando para una versión de MySQL superior a la 5.0.2?
Responda
-
CHANGE USER root TO nuevo_user
-
REVOKE USER root TO nuevo_user
-
RENAME USER root TO nuevo_user
-
No existe la opción de renombrar un usuario
Questão 11
Questão
Se necesita repetir el último comando ejecutado en una consola Linux con el Shell por defecto bash. ¿Cuál de los siguientes permite realizarlo?
Questão 12
Questão
Si fuese necesario, ¿con qué comando se restauran los metadatos de un grupo de volúmenes de LVM?
Responda
-
vgcfgrestore
-
lvmgrestore
-
importlvm
-
lvmrestore
Questão 13
Questão
El comando para inicializar la partición /dev/sdb1 para ser usada por LVM es:
Questão 14
Questão
¿Cuál de las siguientes afirmaciones es cierta sobre el gestor de volúmenes lógicos de Linux LVM 2.0 (Logical Volume Manager Versión 2)?
Responda
-
Un volumen lógico (LV) puede pertenecer a distintos grupos de volúmenes lógicos (LVG).
-
Un disco físico solo puede pertenecer a un volumen físico (PV).
-
Un grupo de LVG se puede formar a partir de varios PV.
-
El número de LV incluidos en un grupo de LVG debe ser siempre par.
Questão 15
Questão
Indique con qué orden, de las siguientes, aumentaríamos a 1024 el máximo permitido de ficheros abiertos para el grupo users en el servidor Linux:
Responda
-
echo “users soft nofile 1024” >>/etc/security/filelimits.conf; echo “users hard nofile 1024” >> /etc/security/filelimits.conf
-
echo “users soft nofile 1024” >>/etc/security/files.conf; echo “users hard nofile 1024” >> /etc/security/files.conf
-
echo “@users soft nofile 1024” >>/etc/security/limits.conf; echo “@users hard nofile 1024” >> /etc/security/limits.conf
-
echo “@users soft nofile 1024” >>/etc/security/soft.conf
Questão 16
Questão
El comando que se emplearía para cancelar una orden de “shutdown” pendiente es:
Responda
-
shutdown –u
-
shutdown –off
-
shutdown –cancel
-
shutdown –c
Questão 17
Questão
Indique qué ocurrirá si desde la Shell bash en el servidor Linux, ejecuta lo siguiente:
false && echo “Hola”
Responda
-
La segunda orden (echo “Hola”) no se ejecuta
-
NO existe la orden false, aparece el siguiente error “bash: false: No se encontró la orden”
-
No existe la orden false, pero como se ejecuta en segundo plano al poner &&, se ejecutará echo “Hola”.
-
Sí se ejecuta a orden echo “Hola”
Questão 18
Questão
Mediante la ejecución del comando crontab –e, usted añade la siguiente línea:
0 5 * * 1 tar –zcf /var/backups/home/home.tgz /home/
¿Cuál es el resultado una vez guardado dicho cambio?
Responda
-
Se ejecuta un backup de /home/ a las 5:00 de la mañana una vez a la semana
-
El comando tar da un error de sintaxis
-
El comando tar nunca se llega a ejecutar
-
Se ejecuta un backup de /home/ a las 5:00 de la mañana una vez al mes
Questão 19
Questão
Indique para qué sirve la utilidad “mdadm” en Linux:
Responda
-
Da un error de sintaxis, este comando no existe
-
Para la creación y administración de RAID por software
-
Permite crear enlaces lógicos
-
Para leer un DVD en Linux
Questão 20
Questão
Está instalando una aplicación open source de nube privada, dicha aplicación requiere del uso de Apache y que éste tenga activado el módulo rewrite. ¿Cuál es el comando para activarlo?
Questão 21
Questão
En el servidor Linux, se le ha pedido crear una clave privada RSA, ¿qué comando utilizaría?
Responda
-
a) créate-rsa
-
b) openssl
-
c) joe
-
d) generate
Questão 22
Questão
La vulnerabilidad conocida como heartbleed afecta a:
Responda
-
El servidor de páginas web Apache Webserver
-
El intérprete de tipo Shell en Unix llamado Bash
-
Al software criptográfico OpenSSL
-
Servidores de bases de datos Microsoft SQL Server
Questão 23
Questão
TCP Wrappers es un sistema que permite controlar el acceso a:
Responda
-
los servidores de una máquina UNIX. En concreto, permite filtrar conexiones no deseadas y permite conexiones legítimas. Las reglas que se configuran son muy sencillas haciendo uso de un par de ficheros.
-
Los servidores de una máquina UNIX. En concreto, permite filtrar conexiones no deseadas y permitir conexiones legítimas a un nivel muy bajo de la capa OSI por lo que podemos prescindir del uso de cortafuegos
-
Cada servicio que está corriendo en una máquina UNIX. Para ello es necesario tener instalado el GUI o entorno gráfico que nos permite configurar cada una de las reglas.
-
Cada servicio que está corriendo en una máquina UNIX de manera remota. Es utilizado por los auditores de seguridad cuando se pretende interceptar paquetes TCP en una red. Se acompaña del uso de algún lenguaje de alto nivel como JAVA para su configuración.
Questão 24
Questão
En el servidor Linux (con ip 192.168.1.111) hay un servidor web configurado para servir páginas accediendo a la URL http://192.168.1.111 a través del interfaz eth0:
Tras ejecutar el fichero iptables.sh, si desde un ordenador situado en la misma red accede a la URL mencionada, ¿cuál de las siguientes afirmaciones es cierta?. Contenido de iptables.sh:#!/bin/bash
Iptables –flush
iptables –A INPUT –i eth0 –p tcp –dport 80 –j ACCEPT
iptables –A INPUT –i eth0 –p tcp –dport 80 –j DROP
iptables –A INPUT –i eth0 –p tcp –dport 8888 –j ACCEPT
Responda
-
Se rechazará la conexión al puerto 80, pues se ha creado una regla que impide el acceso
-
Iptables no soporta la opción “flush”
-
Se permite la conexión al puerto 80
-
Iptables no soporta la opción “-j ACCEPT”
Questão 25
Questão
Tras ejecutar el fichero iptables2.sh, si desde un ordenador con navegador situado en la misma red accede a la URL mencionad pero al puerto 8888, ¿cuál de las siguientes afirmaciones es cierta?. Contenido de iptables2.sh:
#!/bin/bash
Iptables –flush
iptables –A INPUT –i eth0 –p tcp –dport 80 –j ACCEPT
iptables –A INPUT –i eth0 –p tcp –dport 80 –j DROP
iptables –A INPUT –i eth0 –p tcp –dport 8888 –j ACCEPT
iptables –A PREROUTING –t nat –i eth0 –p tcp –dport 8888 –j REDIRECT –to-port 80
Responda
-
Hay opciones no soportadas, con lo que no se crearán las reglas
-
No se permite acceso al puerto 80, pero sí al 8888
-
No se permite acceso al puerto 8888
-
La página se mostrara al acceder al puerto 8888
Questão 26
Questão
Tras ejecutar el fichero iptables3.sh, si desde un ordenador con navegador situado en la misma red accede a la URL mencionad pero al puerto 8888, ¿cuál de las siguientes afirmaciones es cierta?. Contenido de iptables3.sh:
#!/bin/bash
Iptables –flush
iptables –A INPUT –i eth0 –p tcp –dport 80 –j ACCEPT
iptables –A INPUT –i eth0 –p tcp –dport 80 –j DROP
iptables –A INPUT –i eth0 –p tcp –dport 8888 –j ACCEPT
iptables –A PREROUTING –t nat –i eth0 –p tcp –dport 8888 –j REDIRECT –to-port 80
Responda
-
Se redirigen las peticiones TCP del puerto 8888 al puerto 80
-
Se redirigen las peticiones TCP del puerto 80 al puerto 8888
-
Se deniega el acceso al puerto 80
-
Se deniega el acceso al puerto 8888
Questão 27
Questão
¿Cuál de las siguientes herramientas está diseñada para administrar la configuración de sistemas similares a Unix y a Microsoft Windows de forma declarativa y dispone de una interfaz gráfica de gestión?
Responda
-
Puppet
-
Maven
-
Python
-
CheSalt
Questão 28
Questão
Indique el producto de Microsoft que permite la administración de la configuración del cumplimiento y la administración integral de activos de servidores, equipos de escritorio, portátiles y dispositivos móviles:
Responda
-
System Center Data Protection Manager
-
System Center App Controller
-
System Center Configuration Manager
-
System Center Orchestrator
Questão 29
Questão
La distribución de Apache que contiene MySQL, PHP y Perl disponible para cualquiera de los diferentes sistemas operativos se denomina:
Questão 30
Questão
¿Cuál de las siguientes afirmaciones sobre el proyecto XAMPP es CORRECTA?
Responda
-
Las últimas versiones están disponibles para iOS y Android.
-
La versión para Windows contiene SQLite como motor de base de datos por defecto.
-
Incluye PHP y Python como intérpretes de lenguajes de Scripts.
-
La X del nombre significa que está disponible para diferentes sistemas operativos: Windows, GNU/Linux, Solaris y Mac OS X.
Questão 31
Questão
El servidor de aplicaciones de código abierto desarrollado por la Apache Software Foundation se denomina:
Responda
-
Jetty
-
Tomcat
-
Geronimo
-
JBoss
Questão 32
Questão
Señale cuál es una característica de SAMBA:
Responda
-
Es el sistema de archivos de Windows NT.
-
Ejecutarse en plataformas Windows para acceder a servicios de ficheros y de impresión de sistemas Linux o Unix.
-
Ejecutarse en plataformas Unix o Linux para compartir servicios de ficheros y de impresión con sistemas Windows.
-
Ser un sistema de archivos de Linux.
Questão 33
Questão
Señale cómo se denomina la implementación libre del protocolo de archivos compartidos de Microsoft Windows, renombrado recientemente a CIFS, para sistemas de tipo UNIX de forma que se vean como servidores o actúen como clientes en redes de Windows:
Responda
-
Samba.
-
LDAP.
-
Active Directory.
-
Kerberos.
Questão 34
Questão
¿Para qué se utiliza el servicio SMB de Windows?
Responda
-
Para configurar un proxy-inverso en la salida a Internet.
-
Para realizar backups remotos y cronificados.
-
Para compartir archivos e impresoras.
-
Para configurar redes wifi.
Questão 35
Questão
Para poder administrar de forma remota una red de área local, es necesario poder configurar una dirección IP en cada uno de los equipos de red. ¿Qué protocolo permite una asignación dinámica de estas direcciones?
Questão 36
Questão
¿Cuál de los siguientes organismos se encarga de generar y mantener las RFC en internet?
Responda
-
IETF (Internet Engineering Task Force).
-
IAB (Internet Architecture Board).
-
lANA (Internet Assigned Numbers Authority).
-
ISOC (Internet Society).
Questão 37
Questão
El protocolo DHCP (Dynamic Host Configuration Protocol) y DHCPv6 (DHCP for IPv6) están definidos en los documentos:
Responda
-
RFC 792 y RFC 4361, respectivamente.
-
RFC 826 y RFC 3315, respectivamente.
-
RFC 1034 y RFC 4361, respectivamente.
-
RFC 2131 y RFC 3315, respectivamente.
Questão 38
Questão
Indique el número de puerto que debería usarse sí se quiere configurar un servicio para usar el protocolo de configuración dinámica de host DHCP para IPv6:
Questão 39
Questão
¿Cuál es puerto estándar asociado al protocolo Telnet?
Questão 40
Questão
Según la entidad IANA, ¿qué número de puerto TCP está reservado para Telnet?
Questão 41
Questão
La seguridad en la empresa es un activo fundamental por lo que tienen una buena red perimetral y filtran toda las conexiones entrantes. Debido a esta red perimetral no está seguro de si podrá conectarse al puerto 1452 de su empresa (IP 10.25.44.195), en la cual escucha una aplicación a la que necesita conectarse. ¿Cómo podría comprobar usando el comando telnet si el puerto está abierto?
Questão 42
Questão
Para poder configurar correctamente las reglas del firewall, indique cuál es el puerto por defecto de MySQL:
Questão 43
Questão
Señale en qué estructura de datos se basan los directorios tipo LDAP o similares:
Responda
-
Listas.
-
Arrays.
-
Árboles.
-
Colecciones.
Questão 44
Questão
Indique qué afirmación en relación al protocolo LDAP es VERDADERA:
Responda
-
Es un protocolo para acceder a un directorio X.500 que precisa la pila de protocolos OSI
-
La estructura interna del directorio X.500 está definida mediante el protocolo LDAP
-
Un servidor LDAP siempre requiere que el cliente LDAP se autentique antes de acceder a la información
-
El protocolo LDAP está descrito usando ASN.1.
Questão 45
Questão
Señalar cuál de las siguientes NO es una ventaja del uso de directorios LDAP para la autenticación de usuarios:
Responda
-
La mayoría de aplicaciones comerciales permiten su integración fácilmente.
-
Están optimizados para las búsquedas, que es la operación más repetida a la hora de gestionar los usuarios.
-
Permiten implantar sin ningún mecanismo adicional Single Sign On, ya que todas las aplicaciones pueden tener la autenticación a través del LDAP.
-
La replicación con los directorios /etc/passwd está automatizada, y por tanto la integración con las aplicaciones comerciales.
Questão 46
Questão
El servidor 192.168.0.100 está sirviendo una página web usando Apache y a través del puerto 80, ¿cuál sería el comando, disponible en el paquete apache2-utils, para obtener información del rendimiento, tales como peticiones por segundo?
Responda
-
ab http://192.168.0.100
-
apache_test http://192.168.0.100
-
wget http://192.168.0.100
-
curl http://192.168.0.100