Mindmap
DHCP
Inhalt der Mindmap
DHCP
CONCEPTO
- Protocolo de configuración dinámica de host
- Es un servidor que usa protocolo de red de tipo cliente/servidor
- Gneralmente un servidor posee una lista de direcciones IP dinámicas
- Es un servidor que usa protocolo de red de tipo cliente/servidor
- DHCP se definió por primera vez como un protocolo de seguimiento estático de las normas en el RFC 1531 en octubre de 1993.
- como una extensión del protocolo Bootstrap (BOOTP)
- RFC
- Se publicó en octubre de 1993, y su implementación actual está en la RFC 2131
- DHCPv6 fue documentado originalmente en el RFC 3315 en 2003 y luego complementado por muchos otros RFC.
- El RFC 3633 añadió un mecanismo de delegación de prefijo para DHCPv6.
- DHCPv6 se amplió aún más para proporcionar información a los clientes con la configuración automática de direcciones sin estado en el RFC 3736
- El RFC 3633 añadió un mecanismo de delegación de prefijo para DHCPv6.
- DHCPv6 fue documentado originalmente en el RFC 3315 en 2003 y luego complementado por muchos otros RFC.
- Se publicó en octubre de 1993, y su implementación actual está en la RFC 2131
- Protocolo de configuración dinámica de host
ASIGANACIÓN DE DIRECCIONES IP
- Cada dirección IP debe configurarse manualmente en cada dispositivo
- si el dispositivo se mueve a otra subred, se debe configurar otra dirección IP diferente
- El DHCP le permite al administrador supervisar y distribuir de forma centralizada las direcciones IP necesarias
- Y automáticamente, asignar y enviar una nueva IP si fuera el caso en que el dispositivo es conectado en un lugar diferente de la red.
- El protocolo DHCP incluye tres métodos de asignación de direcciones IP
- Asignación manual o estática
- Asigna una dirección IP a una máquina determinada. Se suele utilizar cuando se quiere controlar la asignación de dirección IP a cada cliente, y evitar, también, que se conecten clientes no identificados.
- Asignación automática
- Asigna una dirección IP a una máquina cliente la primera vez que hace la solicitud al servidor DHCP y hasta que el cliente la libera. Se suele utilizar cuando el número de clientes no varía demasiado.
- Asignación dinámica
- El único método que permite la reutilización dinámica de las direcciones IP. El administrador de la red determina un rango de direcciones IP y cada dispositivo conectado a la red está configurado para solicitar su dirección IP al servidor cuando la tarjeta de interfaz de red se inicializa
- Asignación manual o estática
- Cada dirección IP debe configurarse manualmente en cada dispositivo
PARAMETROS CONFIGURABLES
- Un servidor DHCP puede proveer de una configuración opcional al dispositivo cliente
- Dichas opciones están definidas en el RFC 2132
- Algunas de las opciones configurables
- Dirección del servidor DNS
- Nombre DNS
- Puerta de enlace de la dirección IP
- Dirección de Publicación Masiva (broadcast address)
- Máscara de subred
- Tiempo máximo de espera del ARP (Protocolo de Resolución de Direcciones según siglas en inglés)
- MTU (Unidad de Transferencia Máxima según siglas en inglés) para la interfaz
- Servidores NIS (Servicio de Información de Red según siglas en inglés)
- Dominios NIS
- Servidores NTP (Protocolo de Tiempo de Red según siglas en inglés)
- Servidor SMTP
- Servidor TFTP
- Nombre del servidor de nombres de Windows (WINS)
- Un servidor DHCP puede proveer de una configuración opcional al dispositivo cliente
ANATOMÍA DEL PROTOCOLO
- DHCP Discovery
- Es una solicitud DHCP realizada por un cliente de este protocolo para que el servidor DHCP de dicha red de computadoras le asigne una dirección IP y otros Parámetros DHCP como la máscara de red o el nombre DNS.
- DHCP Offer
- Es el paquete de respuesta del Servidor DHCP a un cliente DHCP ante su petición de la asignación de los Parámetros DHCP.
- Involucra su dirección MAC (Media Access Control).
- Es el paquete de respuesta del Servidor DHCP a un cliente DHCP ante su petición de la asignación de los Parámetros DHCP.
- DHCP Request
- El cliente selecciona la configuración de los paquetes recibidos de DHCP Offer.
- Una vez más, el cliente solicita una dirección IP específica que indicó el servidor
- El cliente selecciona la configuración de los paquetes recibidos de DHCP Offer.
- DHCP Acknowledge
- El servidor reconoce la solicitud y la envía acuse de recibo al cliente del cliente, se inicia la fase final del proceso de configuración
- Esta fase implica el reconocimiento con el envío de un paquete al cliente.
- Este paquete incluye la duración de la concesión y cualquier otra información de configuración que el cliente pueda tener solicitada.
- En este punto, el proceso de configuración TCP/IP se ha completado.
- Este paquete incluye la duración de la concesión y cualquier otra información de configuración que el cliente pueda tener solicitada.
- Esta fase implica el reconocimiento con el envío de un paquete al cliente.
- El servidor reconoce la solicitud y la envía acuse de recibo al cliente del cliente, se inicia la fase final del proceso de configuración
- DHCP Discovery
Informationen
- Beschreibung
- REDES EMERGENTES Mindmap am DHCP, erstellt von Uriel Hidalgo am 23/11/2016.
- Erstellt von
- Uriel Hidalgo
- Aufrufe
- 17
- Tags
- Bewertung