¡GoConqr estrena diseño! Cuéntanos qué te parece.

Diapositivas

Sin título

ana medina Español 14 diapositivas

Sin título

Diapositivas del conjunto (14)

  1. OSPF. INTRODUCCIÓN

    • DEFINICIÓN: Open Shortest Path First (OSPF) : Es un protocolo de enrutamiento de estado de enlace desarrollado como reemplazo del protocolo de enrutamiento por vector de distancia: RIP.
    • RIP estableció un protocolo de enrutamiento aceptable en los comienzos del networking y de internet.
    • OSPF es un protocolo de enrutamiento sin clase que utiliza el concepto de áreas para realizar la escalabilidad
    • RFC 2328 define la mètrica OSPF como un valor arbitrario llamado costo.
    • El IOS de CISCO utiliza el ancho de banda como la mètrica de costo de OSPF.
    • Las principales ventajas de OSPF frente a RIP son su rápida convergencia y escabilidad a implementaciones de redes mucho mayores.
    • OSPF. INTRODUCCIÓN
  2. Diapositiva 2

    • Sin título
  3. LO QUE HAY QUE APRENDER

    • Describir las características básicas y de fondo de OSPF.
    • Identificar y aplicar los comandos básicos de configuración OSPF.
    • Describir,modificar y calcular la métrica utilizada por OSPF.
    • Describir el proceso de elección del router designado y del router designado de respaldo (DR/BDR) en las redes de acceso múltiple.
    • Emplear el comando default-information originate para configurar y propagar una ruta por defecto en OSPF.
  4. INFORMACIÓN BÁSICA DEL OSPF

    • El desarrollo inicial del OSPF comenzó en 1987 por un grupo de trabajo de OSPF de ingenieria de internet (IETF).
    • La especificación para OSPFV1 se publicó en RFC 1131, con dos implementaciones desarrolladas, una para ejecutar en routers y otra para ejecutar en estaciones de trabajo UNIX.
    • EN 1991 John Moy introdujo OSPFV2 en RFC 1247. Mientras OSPFV2 ofrecía mejores técnicas, ISO trabajaba en un protocolo de enrutamiento de estado de enlace propio, Intermediate System-to-Intermediate System (IS-IS).
    • En 1998, la especificación OSPFv2 se actualizó en RFC 2328 y representa la RFC actual para OSPF.
  5. Diapositiva 5

    • Sin título
  6. ENCAPSULACIÓN DE MENSAJES OSPF

    • La porción de datos de un mensaje OSPF se encapsula en un paquete.
    • Este campo de datos puede incluir uno de cinco tipos de paquetes OSPF.
    • El encabezado del paquete OSPF se incluye con cada paquete OSPF, independientemente de su tipo.
    • El encabezado del paquete OSPF y los datos específicos según el tipo de paquete específico se encapsulan luego en un paquete IP.
    • En el encabezado del paquete IP, el campo Protocolo se establece en 89 para indicar el OSPF y la dirección de destino se establece para una de dos direcciones multicast:224.0.0.5 ó 224.0.0.6.
    • Si el paquete OSPF se encapsula en una trama de Ethernet, la dirección MAC de destino es también una dirección multicast: 01-00-5E-00-05 Ó 01-00-5E-00-00-06.
  7. Diapositiva 7

    • Sin título
  8. TIPOS DE PAQUETES OSPF

    • La anterios imagen muestra los cinco tipos diferentes de LSP de OSPF. Cada paquete cumple una función en el proceso de enrutamiento de OSPF.
    • Saludo: Los paquetes de saludo se utilizan para establecer y mantener junto con otros routers OSPF.
    • DBD: el paquete de Descripción de bases (DBD) incluye una lista de la base de datos de estado de enlace del router emisor y lo utilizan los routers receptores para comparar con la base de datos de estado de enlace local.
    • LSR: los routers receptores pueden luego solicitar más información acerca de una entrada en la DBD enviando una Solicitud de estado de enlace (LSR).
    • LSU: los paquetes de Actualizacion de estado de enlace (LSU) se utilizan para responder las LSR y para anunciar nueva información.
    • LSAck: cuando se recibe una LSU, el router envia un Acuse de recibo de estado de enlace (LSAck) para confirmar la recepción de LSU.
  9. Diapositiva 9

    • Sin título
  10. PROTOCOLO DE SALUDO

    • En la imagen anterior muestra el encabezado del paquete OSPF y el paquete de saludo. Se enfocará solo en los usos del paquete de saludo.
    • El paquete OSPF Tipo 1 es el paquete de saludo OSPF. Y los paquetes de saludo se utilizan para :
    • Descubrir vecinos OSPF y establecer adyacientes de vecinos.
    • Publicar parámetros en los que dos routers deben acordar convertirse en vecinos.
    • Elegir el Router designado (DR) y el Router designado de respaldo (BDR) en redes de accesos múltiples, como Ethernet y Frmae Relay.
    • Los campos importantes de la imagen anterior son:
    • Tipo: tipo de paquete OSPF ( Saludo, Solicitud LS, Actualización LS, ACK LS.
    • ID del Routeer: ID del router de origen.
    • ID del área: área en la que se originó el paquete.
    • Máscara de red: máscara de subred asociada con la interfaz emisora.
    • Intervalo de saludo: cantidad de segundos entre los paquetes de saludo del router emisor.
    • Prioridad del router: utilizado en la elección de DR/BDR
    • Router designado (dr): ID del router de DR, si existe.
    • Router designado de respaldo (BDR): ID del router del BDR, si existe.
    • Lista de vecinos: enumera la ID del router OSPF de los routers vecinos.
  11. Diapositiva 11

    • Sin título
  12. ESTABLECIMIENTO DE VECINOS

    • Antes de que un router OSPF pueda saturar a otros routers con sus estados de enalces, primero debe determinar si existe otro vecino OSPF en alguno de sus enlaces.
    • En la imagen, los routers OSPF envían paquetes de saludo a todas las interfaces habilitadas con OSPF para determinar si hay vecinos en los enlaces.
    • La información en el saludo de OSPF incluye la ID del router que envía el paquete de saludo.
    • La recepción de un paquete de saludo OSPF en una interfaz confirma a un router la presencia de otro router OSPF en dicho enlace.
    • OSPF luego establece la adyacencia con el vecino.
  13. INTERVL. MUERTO Y DE SALUDO DE OSPF

    • Antes de que dos routers puedan formar una dyacencia de vecinos OSPF, éstos deben estar de acuerdo con respecto a tres valores:
    • intervalo de saludo
    • intervalo muerto
    • tipo de red
    • De manera predeterminada, los paquetes de saludo OSPF se envían cada 10 segundos en segmentos multiacceso y punto a punto, y cada 30 segundos en segmentos multiacceso sin broadcast (NBMA) (Frame Relay,X.25, ATM).
    • En la mayoría de los casos, los paquetes de saludo OSPF se envían como multicast a una dirección reservada para ALLSPFRouters en 224.0.5.
    • La utilización de una dorección multicast permite a un dispositivo ignorar el paquete si la interfaz no está habilitada para aceptar paquetes OSPF.
    • Esto ahorra tiempo de procesamiento de CPU en los dispositivos que no son OSPF.
    • El intervalo muerto es el período, expresado en segundos, que el router esperará para recibir un paquete de slaudo antes de declarar al vecino "desactivado".
    • Cisco utiliza en forma preterminada cuatro veces el intervalo de Hello.
    • En el caso de los segmentos multiacceso y punto a punto, dicho período es de 40 segundos.
    • En el caso de las redes NBMA, el intervalo muerto es de 120 segundos.
    • Si el intervalo muerto expira antes de que los routers reciban un paquete de saludo, OSPF retirará a dicho vecino de su base de datos de estado de enlace.
    • El router satrua con la información de estado acerca del vecino "deactivado" desde todas las interfaces habilitadas con OSPF.
  14. SELECCIÓN DE DR Y BDR

    • Para reducir la cantidad de tráfico de OSPF en redes de accesos múltiples, OSPF selecciona un Rputer designado (DR) y un Router designado de respaldo (BDR).
    • El DR es responsable de actualizar todos los demás routers OSPF ( LLAMADOS droTHERS)

Información

Descripción
Diapositivas sobre Sin título, creado por ana medina el 16/05/2019.
Creado por
ana medina
Visitas
1
Valoración

Escríbenos

¿Sobre qué es tu mensaje?

¿Qué te parece el nuevo diseño?

¿Te gusta?