Mapa mental
Servicios de datos

Conteúdo do mapa
Servicios de datos
TCP/IP
- Conjunto de protocolos. La sigla TCP/IP significa "Protocolo de control de transmisión/Protocolo de Internet
- Originalmente se creó con fines militares, está diseñado para cumplir con una cierta cantidad de criterios, entre ellos:
- Dividir mensajes en paquetes;
- Usar un sistema de direcciones;
- Enrutar datos por la red;
- detectar errores en las transmisiones de datos.
- Su desarrollo estuvo a cargo del Departamento de Defensa de los Estados Unidos, que en 1972 logró ponerlo en práctica al ejecutarlo en una red de área extensa conocida como ARPANET.
- El modelo TCP/IP, influenciado por el modelo OSI, también utiliza el enfoque modular (utiliza módulos o capas), pero sólo contiene cuatro
- Capa de acceso a la red: especifica la forma en la que los datos deben enrutarse, sea cual sea el tipo de red utilizado;
- enrutamiento de datos por la conexión;
- coordinación de la transmisión de datos (sincronización);
- formato de datos;
- conversión de señal (análoga/digital);
- detección de errores a su llegada
- Capa de Internet: es responsable de proporcionar el paquete de datos (datagrama);
- protocolo IP;
- protocolo ARP;
- protocolo ICMP;
- protocolo RARP;
- protocolo IGMP.
- Capa de transporte: brinda los datos de enrutamiento, junto con los mecanismos que permiten conocer el estado de la transmisión;
- TCP, un protocolo orientado a conexión que brinda detección de errores;
- UDP, un protocolo no orientado a conexión en el que la detección de errores es obsoleta.
- Capa de aplicación: incorpora aplicaciones de red estándar (Telnet, SMTP, FTP, etc.).
- servicios de administración de archivos e impresión (transferencia)
- servicios de conexión a la red;
- servicios de conexión remota;
- diversas utilidades de Internet.
- Capa de acceso a la red: especifica la forma en la que los datos deben enrutarse, sea cual sea el tipo de red utilizado;
- Originalmente se creó con fines militares, está diseñado para cumplir con una cierta cantidad de criterios, entre ellos:
- Conjunto de protocolos. La sigla TCP/IP significa "Protocolo de control de transmisión/Protocolo de Internet
ARP
- s un protocolo de comunicaciones de la capa de red, responsable de encontrar la dirección de hardware (Ethernet MAC) que corresponde a una determinada dirección IP
- ARP se utiliza en cuatro casos referentes a la comunicación entre dos hosts:
- Cuando dos hosts están en la misma red y uno quiere enviar un paquete a otro.
- Cuando dos hosts están sobre redes diferentes y deben usar un gateway o router para alcanzar otro host
- Cuando un router necesita enviar un paquete a un host a través de otro router.
- Cuando un router necesita enviar un paquete a un host de la misma red.
- Cuando un router necesita enviar un paquete a un host a través de otro router.
- Cuando dos hosts están sobre redes diferentes y deben usar un gateway o router para alcanzar otro host
- (broadcast, MAC = FF FF FF FF FF FF)
- Cuando dos hosts están en la misma red y uno quiere enviar un paquete a otro.
- Reverse ARP (RARP)
- Las especificaciones del RARP se encuentran en RFC 903
- Es un protocolo para obtener la dirección IP perteneciente a un determinado hardware electrónico que se encuentra en la mayoría de las veces en una red Ethernet
- está disponible en otras redes de área local como lo son la Interfaz de Fibra de Distribución de Datos y las redes LAN Token Ring,
- Es un protocolo para obtener la dirección IP perteneciente a un determinado hardware electrónico que se encuentra en la mayoría de las veces en una red Ethernet
- Las especificaciones del RARP se encuentran en RFC 903
- Inverse ARP (InARP)
- Es traducir las direcciones de la capa de red (capa 3) a direcciones de la capa de enlace de datos (capa 2).
- InARP no envía solicitudes porque conoce la dirección de la estación destino.
- InARP sucede cada 60 segundos predeterminadamente en los circuitos virtuales que se encuentran activos.
- InARP no envía solicitudes porque conoce la dirección de la estación destino.
- Es traducir las direcciones de la capa de red (capa 3) a direcciones de la capa de enlace de datos (capa 2).
- ARP Proxy
- permite a los hosts de una subred alcanzar subredes remotas sin la necesidad de configurar el enrutamiento o la puerta de enlace predeterminada (gateway).
- ARP Proxy se define en RFC 1027
- permite a los hosts de una subred alcanzar subredes remotas sin la necesidad de configurar el enrutamiento o la puerta de enlace predeterminada (gateway).
- ARP se utiliza en cuatro casos referentes a la comunicación entre dos hosts:
- s un protocolo de comunicaciones de la capa de red, responsable de encontrar la dirección de hardware (Ethernet MAC) que corresponde a una determinada dirección IP
FTP
- (Protocolo de transferencia de archivos). La implementación del FTP se remonta a 1971 cuando se desarrolló un sistema de transferencia de archivos (descrito en RFC141) entre equipos del Instituto Tecnológico de Massachusetts (MIT, Massachusetts Institute of Technology).
- Permitir que equipos remotos puedan compartir archivos
- Permitir la independencia entre los sistemas de archivo del equipo del cliente y del equipo del servidor
- Permitir una transferencia de datos eficaz
- procesos que permiten la administración de estos dos tipos de información:
- DTP (Proceso de transferencia de datos) es el proceso encargado de establecer la conexión y de administrar el canal de datos.
- El DTP del lado del servidor se denomina SERVIDOR DE DTP y el DTP del lado del cliente se denomina USUARIO DE DTP.
- PI (Intérprete de protocolo) interpreta el protocolo y permite que el DTP pueda ser controlado mediante los comandos recibidos a través del canal de control. Esto es diferente en el cliente y el servidor:
- DTP (Proceso de transferencia de datos) es el proceso encargado de establecer la conexión y de administrar el canal de datos.
- Los comandos FTP son cadenas de caracteres Telnet (en código NVT-ASCII) que finalizan con el código de final de línea Telnet (es decir, la secuencia <CR>+<LF>, Retorno de carro seguido del carácter Avance de línea indicado como <CRLF>).
- El puerto utilizado
- El método de transferencia de datos
- La estructura de datos
- La naturaleza de la acción que se va a realizar (Recuperar, Enumerar, Almacenar, etc.)
- Existen tres tipos de comandos FTP diferentes
- Comandos de parámetros de transferencia
- Comandos de servicio FTP
- Comandos de control de acceso
- Comandos de parámetros de transferencia
- (Protocolo de transferencia de archivos). La implementación del FTP se remonta a 1971 cuando se desarrolló un sistema de transferencia de archivos (descrito en RFC141) entre equipos del Instituto Tecnológico de Massachusetts (MIT, Massachusetts Institute of Technology).
SMTP
- protocolo para transferencia simple de correo”, es un protocolo de red utilizado para el intercambio de mensajes de correo electrónico entre computadoras u otros dispositivos
- (PDA, teléfonos móviles, impresoras, etc)
- Diseñado el primer sistema para intercambiar correos electrónicos en ARPANET, definido en los Request for comments RFC 821 y RFC 822
- Una transacción de SMTP se compone de tres
- MAIL: comando para establecer la dirección de retorno, también conocido como Return-Path, remitente o sobre. Esta es la dirección para mensajes de despedida.
- RCPT: comando, para establecer un destinatario de este mensaje. Este mandato puede emitirse varias veces, una para cada destinatario. Estas direcciones son también parte de la envolvente
- DATA: para enviar el mensaje de texto. Este es el contenido del mensaje, en lugar de su envoltura. Se compone de una cabecera de mensaje y el cuerpo del mensaje separado por una línea en blanco.
- Funcionamiento del protocolo SMTP
- HELO, para abrir una sesión con el servidor
- MAIL FROM, para indicar quien envía el mensaje
- RCPT TO, para indicar el destinatario del mensaje
- DATA, para indicar el comienzo del mensaje, éste finalizará cuando haya una línea únicamente con un punto
- QUIT, para cerrar la sesión
- RSET Aborta la transacción en curso y borra todos los registros.
- SEND Inicia una transacción en la cual el mensaje se entrega a una terminal.
- SOML El mensaje se entrega a un terminal o a un buzón.
- SAML El mensaje se entrega a un terminal y a un buzón.
- VRFY Solicita al servidor la verificación de todo un argumento
- EXPN Solicita al servidor la confirmación del argumento.
- HELP Permite solicitar información sobre un comando.
- NOOP Se emplea para reiniciar los temporizadores
- TURN Solicita al servidor que intercambien los papeles
- Funcionamiento del protocolo SMTP
- protocolo para transferencia simple de correo”, es un protocolo de red utilizado para el intercambio de mensajes de correo electrónico entre computadoras u otros dispositivos
POP
- Post Office Protocol (Protocolo de Oficina de Correos).
- a diferencia de SMTP el POP no necesita una conexión permanente a internet
- APOP — POP3 con autenticación MDS. En este protocolo, el cliente de correo envía un hash codificado de la contraseña al servidor en lugar de enviar una contraseña encriptada.
- KPOP — POP3 con autenticación Kerberos
- RPOP — POP3 con autenticación RPOP, que utiliza un identificador de usuario similar a una contraseña para autenticar las peticiones POP. No obstante, este ID no esta encriptado por tanto RPOP no es más seguro que el estándar POP.
- servidor POP dedicado recibe el correo para usuarios autorizados y les permite recogerlo a través de la red. Un servidor de estas características tiene tres componentes esenciales:
- Almacenamiento de buzones: almacenando los mensajes entrantes en disco.
- Servicio de buzones: permitiendo a los usuarios recoger el correo a través de la red.
- Gestión de cuentas: establecimiento de contraseñas para los usuarios autorizados.
- Opciones comunes compatibles con sendmail.
- Almacenamiento de buzones: formato mbox en /var/spool/mail/$USUARIO
- Opciones comunes compatibles con sendmail.
- Gestión de cuentas: establecimiento de contraseñas para los usuarios autorizados.
- Servicio de buzones: permitiendo a los usuarios recoger el correo a través de la red.
- Existen dos versiones principales de este protocolo, POP2 y POP3, a los que se le asignan los puertos 109 y 110 respectivamente, y que funcionan utilizando comandos de texto radicalmente diferentes.
- el protocolo POP (POP2 y POP3) funciona con comandos de texto enviados al servidor POP. Cada uno de estos comandos enviados por el cliente (validados por la cadena CR/LF)
- a diferencia de SMTP el POP no necesita una conexión permanente a internet
- Post Office Protocol (Protocolo de Oficina de Correos).
Imagens e arquivos do mapa
Informações
- Descrição
- Mapa Mental sobre Servicios de datos, criado por GUSTAVO SEGURA em 25-10-2016.
- Criado por
- GUSTAVO SEGURA
- Visualizações
- 1
- Avaliação
Mais sobre Modelos OSI y TCP/IP




