GoConqr hat ein neues Design! Sag uns, wie es dir gefällt.

Mindmap

TCP/IP

Aarón Hernández Spanisch

TCP/IP

Inhalt der Mindmap

TCP/IP

  1. Conjunto de protocolos para comunucaciones de datos.

  2. Toma el nombre de sus protocolos más importantes TCP e IP.

  3. En 1969 ARPA desarrolló un proyecto experimental de red conmutada de paquetes al que denominó ARPAnet.

    • ARPAnet comenzó a ser operativa en 1975.
    • En 1990 ARPAnet deja de existir oficialmente.
  4. Los estandares del protocolo son abiertos y soportados por todo tipo de sistemas.

  5. Funciona sobre cualquier tipo de medio.

  6. Emplea un esquema de direccionamiento que asigna a cada equipo conectado una dirección única en toda la red.

  7. Todos los estandares descritos para los protocolos TCP/IP son publicados como RFC(Request for Comments)

    • Detallan lo relacionado con la tecnología de la que se sirve internet.
      • Protocolos, recomendaciones, comunicaciones, etc.
  8. ARQUITECTURA DE TCP/IP

    • Correspondencia del modelo OSI con TCP/IP.
      • CAPA DE ACCESO A RED
        • Ubicada en el nivel más bajo de la jerarquía del protocolo.
        • Define como encapsular un datagrama IP en una trama que puede ser transmitida por la red.
          • Descrito en la RFC 894
        • Dentro de ésta capa opera el protocolo ARP.
          • Asocia las direcciones lógicas IP a direcciones físicas de los dispositivos adaptadores de red (NIC).
          • El estándar RFC 826 describe su funcionamiento.
      • CAPA DE INTERNET
        • El protocolo IP es el protagonista de este nivel.
          • IPV4 -> IPV6
          • Diseñado para redes de paquetes no orientados a conexión.
          • No comprueba si se han producido errores de transmisión.
          • Para el protocolo IP un datagrama es el formato que debe tener un paquete de datos en la capa de red.
            • Para cada datagrama IP consulta la dirección origen(palabra 4) y la compara con la dirección destino(palabra 5).
              • Origen y destino corresponden con equipos de la misma red.
                • El datagrama se envía.
              • Los equipos pertenecen a diferentes redes.
                • Intervención necesaria de una puerta de enlace o gateway.
        • Protocolo ICMP
          • Internet Control Message Protocol
          • Envía mensajes en forma de datagramas que permiten:
            • Control de flujo.
            • Detección de destinos inalcanzables.
              • Cuando la dirección destino de un datagrama no logra ser asociada a ningún equipo.
            • Redireccionamiento de rutas.
              • Mediante un mensaje ICMP se indica que hay otra puerta de enlace en la misma red.
            • Pruebas de conectividad.
              • Se emplea el comando ping.
                • Ofrece información del tiempo que tardan en ir y volver los paquetes.
          • RFC 792
      • CAPA DE TRANSPORTE
        • Presentes los protocolos TCP y UDP.
          • TCP
            • Envía datos de extremo a extremo con posibilidad de detectar errores y corregirlos.
            • Orientado a conexión.
            • Los datos son una secuencia continua de bytes.
          • UDP
            • Reduce información incluida en la cabecera del datagrama
            • Gana rapidez a costa de fiabilidad.
      • CAPA DE APLICACIÓN
        • Capa más alta del protocolo TCP/IP
        • Incluye las aplicaciones y procesos con los que intercambia datos la capa de transporte.
        • Tiene protocolos que soportan servicios de conexión remota, correo electrónico y transferencia de archivos.
          • Telnet
            • Establece conexiones con terminales remotos.
          • FTP
            • Protocolo orientado a la conexión dedicado a la transferencia de archivos.
          • SMTP
            • Posibilita el funcionamiento del correo electrónico.
          • HTTP
            • Estándar de Internet que permite la transferencia de gran variedad de archivos.
              • R. Aarón Hernández Hernández
          • DNS
            • Convierte nombres de dispositivos y de nodos de red en direcciones IP.
    • Encapsulado de datos por niveles TCP/IP.

Bilder und Dateien der Mindmap

  • TCP/IP
  • TCP/IP
  • TCP/IP
  • TCP/IP
  • TCP/IP
  • TCP/IP

Informationen

Beschreibung
Mindmap am TCP/IP, erstellt von Aarón Hernández am 11/02/2017.
Erstellt von
Aarón Hernández
Aufrufe
0
Bewertung

Feedback

Worum geht es?

Wie gefällt dir das neue Design?

Dein Eindruck