Mapa mental

Contenido del mapa
Arquitectura
- RFC 821
- Destino Prioridad Seguridad, etc.
- Destino, prioridad, seguridad, etc.
- RFC 822 (Contenido del mensaje)
- Cabecera, Cuerpo, etc
- Cada campo de cabecera consiste en una sola línea de texto ASCII
- Servicios del sistema de correo (Funciones)
- hola
- Edición de mensajes, transferencia, generación de informes
- Subsistemas (AGENTES)
- De transferencia (MTA)
- De distribución
- SMTP, ESMTP (Simple Mail Transfer Protocol) y extendido.
- SMTP
- Estándar oficial de Internet, RFC 821.
- Características
- Protocolo de red utilizado para el intercambio de mensajes de correo electrónico TCP/IP.
- Sencillo y simple, (Cliente/Usuario), creado para ser agil y sin tener en cuenta la seguridad .
- Puerto TCP 25 por defecto, formato ASCII.
- El servidor comienza envia una línea de texto que proporciona su identidad
- ¿Está preparado?
- No. El cliente libera la conexión y lo intenta después.(Relay)
- Si. el cliente anuncia emisor y receptor del mensaje. Si existen, el servidor da al cliente permiso para enviar el mensaje. El cliente lo envía y el servidor lo recibe. Si existe más correo también se envía. Una vez intercambiado en ambas direcciones direcciones, se libera la conexión.
- ¿Está preparado?
- SMTP
- SMTP, ESMTP (Simple Mail Transfer Protocol) y extendido.
- De entrega final
- POP, IMAP
- Permite al usuario gestionar su correo a través de una máquina remota
- De distribución
- De usuario (MUA)
- Es un programa que acepta una variedad de comandos para componer, recibir, contestar los mensajes y manipular los buzones de correo.
- MIME Extensiones multipropósito de correo Internet
- Inicialmente para texto en ASCII 7 bits pero aparecen otros idiomas.
- Content transfer encoding
- Indica la manera en que está envuelto el cuerpo para su transmisión
- Esquemas de codificación
- ASCII 7:No excede de 1000 caracteres
- ASCII 8: Esquema que viola el protocolo, Excede 1000 caractéres.
- Codificación binaria: Utilizan los 8 bits no respeta 1000 caracteres por línea. Los programas ejecutables caen en esta categoría.
- Base64: Se divide grupos de 24 bits en unidades de 6 bits (26 mayus, 26 minus, 10 dígitos ), cada unidad es carácter ASCII legal.
- Entrecomillada: Es ASCII de 7 bits, caracteres por encima de 127 codificados como un signo de "=" seguido del valor del carácter en dos dígitos hexadecimales. Se utiliza en el caso de mensajes que son casi completamente ASCII, pero con algunos caracteres no ASCII.
- Esquemas de codificación
- Indica la manera en que está envuelto el cuerpo para su transmisión
- Content type
- Especifica la forma del cuerpo del mensaje.
- Content transfer encoding
- Serie de convenciones o especificaciones dirigidas al intercambio, a través de Internet, de todo tipo de archivos de forma transparente para el usuario.
- Características
- RFC 1341,1521 & 2045 se continúa usando el RFC 822, pero permite agregar una estructura al cuerpo del mensaje y definir reglas de codificación para los mensajes no ASCII.
- Sólo afecta a los agentes de usuario, ya que para SMTP es totalmente transparente.
- Nada cambia respecto a la arquitectura
- Características
- Inicialmente para texto en ASCII 7 bits pero aparecen otros idiomas.
- MIME Extensiones multipropósito de correo Internet
- Es un programa que acepta una variedad de comandos para componer, recibir, contestar los mensajes y manipular los buzones de correo.
- De transferencia (MTA)
- RFC 821
Imágenes y archivos del mapa
Información
- Descripción
- Mapa Mental sobre E-Mail, creado por PANCHO READO el 17/02/2017.
- Creado por
- PANCHO READO · feb 2017
- Actualizado
- 17 feb 2017
- Visitas
- 0
- Valoración