¡GoConqr estrena diseño! Cuéntanos qué te parece.

Mapa mental

Los protocolos de Red

davidabrahamquip Español

Contenido del mapa

Los protocolos de Red

  1. ¿Qué es TCP/IP?

    • El nombre “TCP/IP” se refiere a una suite de protocolos de datos. El nombre viene de 2 de los protocolos que lo conforman: Transmission Control Protocol (TCP) Internet Protocol (IP) Hay muchos otros protocolos en la suite
      • TCP/IP son los protocolos fundamentales de Internet (Aunque se utilizan para Intranets y Extranets) Stanford University y Bold, Beranek and Newman (BBN)
        • Los estándares de los protocolos son abiertos: interconecta equipos de diferentes fabricantes sin problema. Independiente del medio de transmisión físico.
          • Para que los computadores puedan comunicarse necesitan establecerse reglas ó protocolos (AppleTalk, IPX/SPX, SNA,etc.) Los protocolos de TCP/IP no depende del S.O. ni del computador (es “abierto”): cualquiera puede desarrollar productos que se ajusten a las especificaciones de TCP/IP
            • La mayor parte de la información sobre los protocolos de TCP/IP está publicada en unos documentos llamados Request for Comments (RFC’s) - Hay otros dos tipos de documentos: Military Standards (MIL STD), Internet Engineering Notes (IEN)
              • El modelo de referencia OSI
  2. Arquitectura de TCP/IP

  3. Capa de acceso de red (Un ejemplo: el sistema Ethernet)

  4. Capa Internet (IP, ICMP)

  5. Capa de transporte (UDP y TCP)

  6. Capa de aplicaciones

  7. ¿Qué es TCP/IP?

    • El nombre “TCP/IP” se refiere a una suite de protocolos de datos. El nombre viene de 2 de los protocolos que lo conforman: Transmission Control Protocol (TCP) Internet Protocol (IP) Hay muchos otros protocolos en la suite
      • TCP/IP son los protocolos fundamentales de Internet (Aunque se utilizan para Intranets y Extranets) Stanford University y Bold, Beranek and Newman (BBN) presentaron TCP/IP a comienzos de los 70 para una red de conmutación de paquetes
        • Los estándares de los protocolos son abiertos: interconecta equipos de diferentes fabricantes sin problema. Independiente del medio de transmisión físico. Un esquema de direccionamiento amplio y común. Protocolos de alto nivel estandarizados
          • Protocolos: reglas formales de comportamiento Para que los computadores puedan comunicarse necesitan establecerse reglas ó protocolos (AppleTalk, IPX/SPX, SNA,etc.) Los protocolos de TCP/IP no depende del S.O. ni del computador
            • La mayor parte de la información sobre los protocolos de TCP/IP está publicada en unos documentos llamados Request for Comments (RFC’s) - Hay otros dos tipos de documentos: Military Standards (MIL STD), Internet Engineering Notes (IEN)
  8. Arquitectura de TCP/IP

    • No hay un acuerdo sobre como representar la jerarquía de los protocolos de TCP/IP con un modelo de capas (utilizan de tres a cinco).
    • Encapsulación de datos Cada capa de la pila TCP/IP adiciona información de control (un “header”) para asegurar la entrega correcta de los datos. Cuando se recibe, la información de control se retira
  9. Capa de acceso de red (Un ejemplo: el sistema Ethernet)

    • Es la capa inferior de la jerarquía de protocolos de TCP/IP Es equivalente a la capa 1 y 2 del modelo OSI (con algunas funciones de la capa 3). Hay muchos protocolos de acceso a la red (uno por cada estándar físico de red) Encapsula Datagramas en Frames y mapea direcciones IP a direcciones físicas. Ejemplos de RFC’s que definen protocolos de la capa de acceso a red son: RFC826 y RFC894 Esta capa se construye con la tarjeta de red, los drivers y los programas asociados
      • Un ejemplo: el Sistema Ethernet Ethernet es una tecnología de redes de área local (LAN) que transmite información entre computadores a una velocidad de 10 Mbps (Ethernet), 100 Mbps (Fast Ethernet) ó 1000 Mbps (Gigabit Ethernet). Los medios que soporta 10 Mbps son coaxial grueso, coaxial delgado, par trenzado y fibra óptica. Los medios que soporta 100 Mbps son par trenzado y fibra óptica
        • El frame Ethernet El corazón del sistema Ethernet es el frame Ethernet utilizado para llevar datos entre computadores. El “frame” consta de varios bits organizados en varios campos
          • El frame Ethernet Versión 2 Destino: 6 bytes, dirección física del nodo destino (MAC address) Origen: 6 bytes, dirección del nodo origen Tipo: 2 bytes, especifica el protocolo de la capa superior Datos: entre 46 y 1500 bits, información de las capas superiores Chequeo: Secuencia de chequeo del frame Cuando un frame Ethernet es enviado al canal todas las interfaces revisan los primeros 6 bytes (48 bits). Si es su dirección MAC (o broadcast) reciben el paquete y lo entregarán al software de red instalado
            • direcciones Ethernet Los paquetes de los protocolos de alto nivel (como TCP/IP) se mueven entre computadores dentro del campo de datos del frame Ethernet Los protocolos de alto nivel tienen su propio esquema de direcciones (por ejemplo, direcciones IP) El software de red instalado en un equipo conoce su dirección IP
              • 1. “Correo” quiere enviar información a “DNS” a través de la red Ethernet 2. “Correo” envía un paquete con dirección destino broadcast (FF:FF:FF:FF:FF:FF) preguntando: ¿La estación con dirección IP 168.176.1.50 podría decirme cuál es su dirección MAC? (ARP request) 3. Como el ARP request tiene dirección broadcast todas las interfaces recibirán la solicitud, pero sólo responderá el “DNS”
  10. Capa de aplicaciones

    • Capa de aplicación La parte superior de la jerarquía de TCP/IP es la capa de aplicación Hay MUCHOS protocolos de aplicación y se siguen creando. La mayoría proveen servicios directos a los usuarios. En esta capa están todos los procesos que utilizan la capa de transporte para entregar datos.
    • Lista de algunas aplicaciones Telnet: protocolo de terminal de red FTP: transferencia de archivos SMTP: transporta el correo electrónico HTTP: transfiere las páginas Web DNS: servicio de nombres: resuelve nombres de nodos a dirección IP OSPF: intercambia información de enrutamiento SNMP: para administración de la red
    • Resumen TCP/IP es la suite de protocolos de Internet En la charla se utilizó un modelo de 4 capas TCP/IP aprovecha muchas tecnologías de red “física”. Un ejemplo con Ethernet IP: Internet protocol, es el corazón de Internet, también está ICMP TCP y UDP están en la capa de transporte Los protocolos de aplicación son muchos
  11. Capa de transporte (UDP y TCP)

    • Los dos protocolos más importantes de la capa de transporte son: Transmission Control Protocol (TCP) User Datagram Protocol (UDP) TCP provee un servicio de entrega de datos confiable con corrección y detección de errores. UDP provee un servicio “liviano”, con entrega de datos no confiable
      • UDP (User Datagram Protocol) UDP da acceso directo al programa de aplicación al servicio de entrega de datagramas (el servicio ofrecido por IP). Liviano, no confiable (no hay ninguna técnica para verificar que los datos llegaron bien a su destino) Es el más eficiente de los protocolos de la capa de transporte: lleva mensajes pequeños
        • Formato del mensaje UDP Puerto de origen: Número de 16 bits que identifica la aplicación origen (opcional). Puerto destino: Número de 16 bits que identifica la aplicación destino Longitud: Longitud en bytes de todo el User Datagram. Incluyendo header y datos Checksum: Control de chequeo del User Datagram, para saber si está bueno
          • TCP (Transmission Control Protocol) Las aplicaciones o servicios que requieren que el protocolo de transporte garantice la entrega confiable de los datos utilizan TCP: Verifica que los datos son entregados a través de la red exactamente y en la secuencia correcta
            • TCP es orientado a conexión TCP establece una conexión lógica entre nodos que se estén comunicando. Cierta información de control, llamada handshake, se intercambia entre los nodos ANTES de que los datos sean transmitidos
              • TCP es un protocolo de flujo de bytes TCP “ve” los datos que el envía como un flujo continuo (stream) de bytes, NO como paquetes independientes, por eso debe tener cuidado de mantener la secuencia El número de secuencia y el numero de ACK del encabezado del segmento TCP mantienen el seguimiento del “chorro” de bytes.
                • Paso de datos a la capa de aplicación TCP también es el responsable de entregar los datos recibidos de IP a la aplicación correcta en la capa de aplicación. Esto se hace utilizando el número de puerto (palabra 1 del header del segmento) Cada aplicación o servicio tiene su número de puerto bien conocido: HTTP: 80 SMTP: 25 DNS: 53
  12. Capa Internet (IP, ICMP)

    • Capa ubicada sobre la capa de acceso de red El protocolo IP (RFC791) es el corazón de TCP/IP y es el protocolo más importante de la capa Internet IP provee el servicio de entrega de paquetes sobre el cual están construidas las redes TCP/IP Los protocolos sobre y debajo de la capa Internet utilizan el protocolo IP para entregar datos
      • Protocolo Internet (IP)
        • Funciones: Define el datagrama, que es la unidad básica de transmisión en Internet Define el esquema de direccionamiento de internet Características: Es un protocolo connectionless (no intercambia información de control - handshake - para establecer una conexión nodo a nodo antes de transmitir)
          • El datagrama El datagrama es el formato de paquete definido por el Protocolo Internet (IP). Las primeras cinco o seis palabras de 32 bits del datagrama son información de control (el “header”). Se utiliza el IHL (Internet Header Length) para dar la longitud del header
            • Direccionamiento IP Cada interface de red (tarjeta de red) se le asigna una dirección lógica única de 32 bits. La dirección consta de una parte que identifica la red y otra que identifica el nodo:
              • Notación decimal con puntos En lugar de utilizar binarios para representar la dirección IP: 10101000101100000000000100110010 Podemos separarlos en bytes (8 bits): 10101000101100000000000100110010 y representarlos en forma decimal 168.176.1.50
                • Direcciones IP reservadas 0.X.X.X 127.X.X.X (dirección de loopback) 128.0.X.X 191.255.X.X 192.0.0.X 223.255.255.X 224.0.0.0 hasta 255.255.255.255
                  • Máscara de subred Una dirección de red la podemos subdividir en subredes pidiendo prestados bits de la parte de identificación de host para identificar la subred
                    • ICMP-Internet Control Message Protocol Definido en el RFC 792, está en la capa Internet y usa el datagrama IP para enviar sus mensajes. Funciones

Información

Descripción
Mapa Mental sobre Los protocolos de Red, creado por davidabrahamquip el 05/01/2015.
Visitas
1
Valoración

Escríbenos

¿Sobre qué es tu mensaje?

¿Qué te parece el nuevo diseño?

¿Te gusta?