¡GoConqr estrena diseño! Cuéntanos qué te parece.

Mapa mental

Técnicas de implementación de QoS

sergio andres castillo colindres Español

Técnicas de implementación de QoS

Contenido del mapa

Técnicas de implementación de QoS

  1. Evitar la pérdida de paquetes

    • La pérdida de paquetes es generalmente el resultado de la congestión en una interfaz. La mayoría de las aplicaciones que utilizan el TCP experimentan una disminución de velocidad debido a que el TCP se ajusta automáticamente a la congestión en la red.
  2. Herramientas de la QoS

    • Herramientas de clasificación y marcación
      • Las sesiones, los flujos, se analizan para determinar qué clase de tráfico a los que pertenecen.
    • Herramientas para evitar la congestión
      • Las clases de tráfico son porciones asignadas de recursos de red, como definido por la directiva QoS.
    • Herramientas de administración de congestión
      • Cuando el tráfico excede los recursos de red disponibles, el tráfico se pone en cola esperar la disponibilidad de recursos.
  3. Clasificación y marcación

    • Antes de que a un paquete se le pueda aplicar una política de la QoS, el mismo tiene que ser clasificado. La clasificación y la marcación nos permiten identificar o “marcar” los tipos de paquetes. La clasificación determina la clase de tráfico al cual los paquetes o tramas pertenecen.
  4. Marcación en la capa 2

    • 802.1Q es el estándar IEEE que admite etiquetado VLAN en la capa 2 de las redes Ethernet. Cuando se implementa 802.1Q, se agregan dos campos a la trama de Ethernet.
  5. Marcación en la capa 3

    • IPv4 e IPv6 especifican un campo de 8 bits en sus encabezados de paquetes para marcar los paquetes.
  6. Tipo de servicio y campo de clase de tráfico

    • El tipo de servicio (IPv4) y la clase de tráfico (IPv6) llevan el marcado de paquetes según lo asignado por las herramientas de clasificación de QoS. Luego se hace referencia al campo mediante dispositivos receptores que reenvían los paquetes en función de la política de QoS asignada apropiada.
  7. Valores DSCP

    • Best-Effort (BE)
      • Este es el valor predeterminado para todos los paquetes IP. El valor de DSCP es 0. El comportamiento por salto es enrutamiento normal.
    • Reenvío acelerado (EF)
      • RFC 3246 define EF como el valor decimal DSCP 46 (binario 101 110). Los primeros 3 bits (101) se asocian directamente al valor 5 de CoS de capa 2 que se utiliza para el tráfico de voz. En la capa 3
    • Reenvío asegurado (AF)
      • RFC 2597 define el AF para usar los 5 bits DSCP más significativos para indicar las colas y la preferencia de descarte.
  8. Bits selectores de clase

    • Como los primeros 3 bits más significativos del campo DSCP indican la clase, estos bits también se denominan bits de selector de clase (CS). Estos 3 bits se asignan directamente a los 3 bits del campo CoS y el campo IPP para mantener la compatibilidad con 802.1py RFC 791
  9. Límites de confianza

    • El tráfico se debe clasificar y marcar lo más cerca de su origen como sea técnicamente y administrativamente posible.
      • Los terminales confiables tienen las capacidades y la inteligencia para marcar el tráfico de aplicaciones con las CoS de capa 2 y / o los valores de DSCP de la Capa 3.
      • Los terminales confiables tienen las capacidades y la inteligencia para marcar el tráfico de aplicaciones con las CoS de capa 2 y / o los valores de DSCP de la Capa 3.
      • El tráfico también puede marcarse en los switches / routers de la capa 3.
  10. Prevención de congestión

    • La gestión de la congestión incluye métodos de colas y programación en los que el tráfico excesivo se almacena o se pone en cola (ya veces se cae) mientras espera que se envíe una interfaz de salida.
  11. Modelado y regulación

    • Las políticas de modelado y de vigilancia del son dos mecanismos proporcionados por el software Cisco IOS QoS para evitar la congestión.
  12. Pautas de directivas deQoS

    • La directiva QoS debe tener en cuenta la ruta completa desde el origen hasta el destino. Si un dispositivo de la ruta de acceso está utilizando una directiva diferente a la deseada, entonces toda la directiva de QoS se ve afectada.
  13. Práctica del módulo y cuestionario

    • ¿Qué aprenderé en este módulo?
      • Calidad de transmisión de red
        • Las transmisiones de voz y vídeo en directo crean mayores expectativas de calidad entre los usuarios y crean una necesidad de calidad de servicio (QoS). La congestión ocurre cuando se agregan varias líneas de comunicación en un solo dispositivo, como un enrutador, y luego gran parte de esos datos se colocan en unas pocas interfaces de salida o en una interfaz más lenta.
      • Características del tráfico
        • El tráfico de voz y video son dos de las principales razones de QoS. El tráfico de voz es suave y benigno, pero es sensible a caídas y retrasos. La voz puede tolerar una cierta cantidad de latencia, fluctuación y pérdida sin efectos aparentes. La latencia no debe superar los 150 milisegundos (ms).
      • Algoritmos de cola
        • La política de la QoS implementada por el administrador de la red se activa cuando se produce una congestión en el enlace. La puesta en cola es una herramienta administrativa para la congestión que puede almacenar en búfer, priorizar, y, si corresponde, reordenar los paquetes antes de que estos se transmitan al destino.
      • Modelos de QoS
        • La estricta PQ permite que los paquetes sensibles al retraso, como la voz, se envíen antes que los paquetes en otras colas, lo que reduzcan la fluctuación en las conversaciones de voz. El modelo Best-esfuerzo es el más escalable, pero no garantiza la entrega y no da ningún tratamiento preferencial de paquetes.
      • Técnicas de implementación de QoS
        • Hay tres categorías de herramientas de QoS: herramientas de clasificación y marcado, herramientas para evitar la congestión y herramientas de gestión de la congestión. Antes de que a un paquete se le pueda aplicar una política de la QoS, el mismo tiene que ser clasificado. La clasificación y la marcación nos permiten identificar o “marcar” los tipos de paquetes. La clasificación determina la clase de tráfico al cual los paquetes o tramas pertenecen. Los métodos de clasificación de flujos de tráfico en la capa 2 y 3 incluyen el uso de interfaces, ACL y mapas de clase.

Imágenes y archivos del mapa

  • Técnicas de implementación de QoS

Información

Descripción
Mapa Mental sobre Técnicas de implementación de QoS, creado por sergio andres castillo colindres el 17/08/2021.
Visitas
0
Valoración

Escríbenos

¿Sobre qué es tu mensaje?

¿Qué te parece el nuevo diseño?

¿Te gusta?