O GoConqr está de visual novo! Conte para nós o que você achou.

Mapa mental

Distributed web system / Service Oriented Architecture

Pavlo Chmykhalo Inglês

Mind map of distributed web system and service oriented architecture: web service, RMI, RPC and CORBA

Mind map: Distributed web system and service oriented architecture

Conteúdo do mapa

Distributed web system / Service Oriented Architecture

  1. Wev Service

    • Serv Requester
    • Service provider
    • Service Oriented Application Protocol
      • Disco File
      • Web Service Description Language
      • UDDI Universal Discovery, Description and Integration
    • XML- Rempte Procedure Call
    • REST
    • XML
      • SAML
    • JSON
  2. RMI

  3. CORBA

  4. DCOM

  5. RPC

    • DCE/RPC — Distributed Computing Environment / Remote Procedure Calls (бинарный протокол на базе различных транспортных протоколов, в том числе TCP/IP и Named Pipes из протокола SMB/CIFS) DCOM — Distributed Component Object Model известный как MSRPC Microsoft Remote Procedure Call или «Network OLE» (объектно-ориентированное расширение DCE RPC, позволяющее передавать ссылки на объекты и вызывать методы объектов через таковые ссылки) ZeroC ICE JSON-RPC— JavaScript Object Notation Remote Procedure Calls (текстовый протокол на базе HTTP) см. спецификацию: RFC-4627 .NET Remoting (бинарный протокол на базе TCP, UDP, HTTP) Java RMI — Java Remote Method Invocation — см. спецификацию: http://java.sun.com/j2se/1.5.0/docs/guide/rmi/index.html SOAP — Simple Object Access Protocol (текстовый протокол на базе HTTP) см. спецификацию: RFC-4227 Sun RPC (бинарный протокол на базе TCP и UDP и XDR) RFC-1831 второе название ONC RPC RFC-1833 XML RPC (текстовый протокол на базе HTTP) см. спецификацию: RFC-352
  6. JINI

  7. OpenID

  8. Ajax

    • Java FX
    • Silverlight
    • WebSocketd
    • Flash

Informações

Descrição
123
Criado por
Pavlo Chmykhalo
Visualizações
37
Tags
123
Avaliação

Mais sobre Distributed Systems and Ubiquitous Computing

Fale Conosco

Sobre o que é sua mensagem?

O que você acha do novo visual?

Você gostou?