GoConqr has a new look! Let us know what you think.

Mind map

POP3 E IMAP

Marcos Otoniel da Silva Portuguese

Map content

POP3 E IMAP

  1. POP3 (POST OFFICE PROTOCOL)

    • É UM PROTOCOLO UTILIZADO NO ACESSO REMOTO A UMA CAIXA DE CORREIO ELETRÔNICO.[1] ELE ESTÁ DEFINIDO NO RFC 1939 E PERMITE QUE TODAS AS MENSAGENS CONTIDAS NUMA CAIXA DE CORREIO ELETRÔNICO POSSAM SER TRANSFERIDAS SEQUENCIALMENTE PARA UM COMPUTADOR LOCAL
    • ESTE PROTOCOLO UTILIZA AS PORTAS TCP 110 (PORTA PADRÃO) OU TCP 995 (CONEXÃO CRIPTOGRAFADA VIA SSL). A PORTA TCP 109 FOI UTILIZADA NA VERSÃO ANTERIOR DO PROTOCOLO (POP2)
    • O FUNCIONAMENTO DO PROTOCOLO POP3 DIZ-SE OFF-LINE, UMA VEZ QUE O PROCESSO SUPORTADO SE BASEIA NAS SEGUINTES ETAPAS:
      • • É ESTABELECIDA UMA LIGAÇÃO TCP ENTRE A APLICAÇÃO CLIENTE DE E-MAIL (USER AGENT - UA) E O SERVIDOR ONDE ESTÁ A CAIXA DE CORREIO (MESSAGE TRANSFER AGENT - MTA)
      • • O UTILIZADOR AUTENTICA-SE;
      • • TODAS AS MENSAGENS EXISTENTES NA CAIXA DE CORREIO SÃO TRANSFERIDAS SEQUENCIALMENTE PARA O COMPUTADOR LOCAL;
      • • AS MENSAGENS SÃO APAGADAS DA CAIXA DE CORREIO (OPCIONALMENTE, O PROTOCOLO PODE SER CONFIGURADO PARA QUE AS MENSAGENS NÃO SEJAM APAGADAS DA CAIXA DE CORREIO; SE ESTA OPÇÃO NÃO FOR UTILIZADA, DEVE-SE UTILIZAR SEMPRE O MESMO COMPUTADOR PARA LER O CORREIO ELETRÔNICO, PARA PODER MANTER UM ARQUIVO DAS MENSAGENS);
      • • A LIGAÇÃO COM O SERVIDOR É TERMINADA;
      • • O UTILIZADOR PODE AGORA LER E PROCESSAR AS SUAS MENSAGENS (OFF-LINE).
    • BAIXA AS MENSAGENS DO SERVIDOR E SALVA AS MESMAS LOCALMENTE EM SEU COMPUTADOR, NÃO DEIXANDO UMA CÓPIA DAS MENSAGENS NO SERVIDOR – A MENOS QUE VOCÊ MARQUE A OPÇÃO “DEIXAR UMA CÓPIA NO SERVIDOR” NAS CONFIGURAÇÕES DO SEU PROGRAMA DE E-MAIL. ESSE PROTOCOLO TEM ACESSO APENAS À CAIXA DE ENTRADA, NÃO CONSEGUINDO BAIXAR NENHUMA OUTRA PASTA DE SUA CONTA.
  2. IMAP (INTERNET MESSAGE ACCESS PROTOCOL)

    • UTILIZA AS PORTAS TCP 143 (PORTA PADRÃO) OU TCP 993 (CONEXÃO CRIPTOGRAFADA VIA SSL)
    • AS MENSAGENS FICAM ARMAZENADAS NO SERVIDOR E O UTILIZADOR PODE TER ACESSO A SUAS PASTAS E MENSAGENS EM QUALQUER COMPUTADOR, TANTO POR WEBMAIL COMO POR CLIENTE DE CORREIO ELETRÔNICO
    • OUTRA VANTAGEM DESTE PROTOCOLO É O COMPARTILHAMENTO DE CAIXAS POSTAIS ENTRE USUÁRIOS MEMBROS DE UM GRUPO DE TRABALHO. ALÉM DISSO, É POSSÍVEL EFETUAR PESQUISAS POR MENSAGENS DIRETAMENTE NO SERVIDOR, UTILIZANDO PALAVRAS-CHAVE.
    • POSSUI ALGUNS INCONVENIENTES:
      • • O NÚMERO DE MENSAGENS POSSÍVEL DE SE ARMAZENAR DEPENDE DO ESPAÇO LIMITE QUE NOS É ATRIBUÍDO PARA A CAIXA DE CORREIO;
      • • CASO O SERVIDOR IMAP ESTEJA NUMA LOCALIZAÇÃO REMOTA, PELA INTERNET, E NÃO NUMA REDE LOCAL LAN, É NECESSÁRIO ESTAR LIGADO À INTERNET TODO O TEMPO QUE QUISERMOS CONSULTAR OU ENVIAR MENSAGENS, OFERECEM A POSSIBILIDADE DE CRIAR UMA CÓPIA LOCAL (OFFLINE) DAS MENSAGENS CONTIDAS EM UMA OU VÁRIAS PASTAS (E.G. INBOX (RECEBIDAS), SENT (ENVIADAS), ETC.). SENDO ASSIM, TODA VEZ QUE VOCÊ DISPUSER DE UMA CONEXÃO (ESTIVER ONLINE) SUA CÓPIA LOCAL SERÁ SINCRONIZADA COM O SERVIDOR DE E-MAIL.
    • ALGUMAS OUTRAS VANTAGENS
      • ATIVAR E DESATIVAR "FLAGS" (MARCAÇÕES QUE INDICAM CARACTERÍSTICAS DE UMA MENSAGEM), QUE PODEM, INCLUSIVE, SER DEFINIDAS PELO USUÁRIO.
      • PERMITE A GRAVAÇÃO DAS "FLAGS" JUNTO ÀS CAIXAS-POSTAIS, ASSEGURANDO QUE, INDEPENDENTE DE QUAL CLIENTE SE ACESSE, AS MENSAGENS TERÃO AS MESMAS CORRETAMENTE ATRIBUÍDAS.
      • CAPACIDADE DE RECONHECER OS PADRÕES DE MENSAGENS ELETRÔNICAS [RFC 822] E MIME-IMB [RFC 2045] EM MENSAGENS ELETRÔNICAS, DE MODO QUE OS CLIENTES DE E-MAIL NÃO O NECESSITEM FAZER
      • CUMPRE A TAREFA DE INTERPRETAR ESTES PADRÕES, TORNANDO OS CLIENTES MAIS FÁCEIS DE IMPLEMENTAR E O ACESSO MAIS "UNIVERSAL"; PESQUISA DE TEXTO EM MENSAGENS DE FORMA REMOTA. ESTE MODO DE TRABALHO É FEITO LOCALMENTE ÀS CAIXAS-POSTAIS
      • A SELEÇÃO PARA RECEBIMENTO DOS ATRIBUTOS DE UMA MENSAGEM, OU SEU TEXTO OU ANEXOS E OUTRAS PARTES ("ATTACHMENTS") PODEM SER FEITOS DE FORMA INDEPENDENTE. ENTÃO, O USUÁRIO PODE PEDIR PARA RECEBER DE UMA MENSAGEM COM UM GRANDE "ATTACHMENT", APENAS A PARTE DO TEXTO QUE LHE INTERESSA, O QUE É VANTAJOSO NO CASO DE UM ACESSO DISCADO DE BAIXA QUALIDADE E A REDUÇÃO DO TRÁFEGO EM GERAL.
  3. PROTOCOLOS DE RECEBIMENTO DE EMAILS ( ENTRADA DE EMAIL)

Information

Description
Mind Map on POP3 E IMAP, created by Marcos Otoniel da Silva on 03/10/2017.
Views
0
Rating

Feedback

What is it about?

What do you think of the new look?

How do you like it?